derp derp! new upderp! 9◡6

Edit: herp derp, new page :P (OP)

Also, forum #88880 get! :3

Munkelzahn
Privileged
4 years ago

Xch3l said:
Hmmm, move that section between the post image and the "Edit | Respond | Download" bar. Well, the tags list can be long (post #329124, 913 tags XP), sure! Wynaut!

Thank you for implementing this feature in version 2.51 ^_^
I just noticed a little bug:
- On posts without a description, "Get Source" appears to the right of "Full Size": post #394582
- But on posts that have a description, it's hidden when the description is open. And when the description is closed, it appears right under the word "Description": post #394568


Munkelzahn said:
Thank you for implementing this feature in version 2.51 ^_^
I just noticed a little bug:
- On posts without a description, "Get Source" appears to the right of "Full Size": post #394582
- But on posts that have a description, it's hidden when the description is open. And when the description is closed, it appears right under the word "Description": post #394568

Fixed on the next update! (same version different code, since it's just a quick edit) it should be up now! (it autoupdates, right?)

Munkelzahn
Privileged
4 years ago

Xch3l said:
Fixed on the next update! (same version different code, since it's just a quick edit) it should be up now! (it autoupdates, right?)

It does, but only if the version number is different.
I've installed the fixed 2.51 manually and now everything works!

Munkelzahn
Privileged
4 years ago

Hi there, I have a new feature request :)

Inkbunny search:
IB lets you search by a pic's MD5 sum. While this isn't as good as a true RIS, it can still be useful. Unfortunately, it's tedious:

1) Copy the link to the full-sized image on e621. Example:
post #399105
Size: 3000x2300 (1.8 MB) ← this is the link
https://static1.e926.net/data/50/c5/50c5082410889a2a13ad70e0d075a772.png

2) Go to the IB search page, tick the "MD5 Hash" checkbox

3) Paste the link from step 1 into the search bar and remove anything except the raw file name. Example:
50c5082410889a2a13ad70e0d075a772

Inkbunny search URL:
https://inkbunny.net/submissionsviewall.php?mode=search&text=50c5082410889a2a13ad70e0d075a772&md5=yes


I'll get into it! I was going to post a new update (some features broke with the new site layout and some optimizations)

Expect it in a while :D The "while" turned out to be longer... anyway, script's updated!


New year? New update!

[01/01/14] Version 2.6 (Code 010114)

  • F: Issue with certain other script, where tabs on the settings page would appear twice twice
  • F: Small bug where the selection in the Add Link button would display more text than it should
  • A: Floating formatting buttons. Just double click on the space (or in between the buttons) to make them float. Double click it again to return it to where it was (for those Wiki/Wall-of-text wrters! ;) )
  • A: Thumbnails on takedown requests
  • A: Comment/Blip/Forum post id (useful in blips, you'll now know who is replying to whom)
  • F: Tag search derps (forum #96652)

As always, you can get it from the same place! Auto update should roll over in a while, if you've installed, of course!

ktkr
Former Staff
4 years ago
2013 :< animated cat cute english_text feline female fur grey_fur lol_comments looking_at_viewer low_res mammal pusheen pusheen_corp simple_background squigglevision text

Rating: Safe
Score: 136
User: snek-
Date: December 10, 2013

Quick bugreport.
Checking how many posts use tag 'banner&flappy' reports 126, yet, there are none.


Xch3l how is it you went through all the trouble if making this script for e6, and update it, while still being a regular member, not even contributor, or whatever comes after member?


Sollux said:
Xch3l how is it you went through all the trouble if making this script for e6, and update it, while still being a regular member, not even contributor, or whatever comes after member?

I don't use the script, but given that Munkle uses it faithfully, I'm surprised on this point myself.


How to install for Chrome on IPAD??


DSR1337 said:
How to install for Chrome on IPAD??

I don't think chrome on ipad supports extensions? I might be wrong.


ktkr said:
Quick bugreport.
Checking how many posts use tag 'banner&flappy' reports 126, yet, there are none.

Thanks! Here's why, script makes a search for banner, which has 126 posts (after the & it considers it as part of the url, pointing to "/post/index?tags=banner&flappy"), I'll fix it asap, wait for it in a few minutes Fixed.

Sollux said:
Xch3l how is it you went through all the trouble if making this script for e6, and update it, while still being a regular member, not even contributor, or whatever comes after member?


Sollux said:
whatever comes after member?

Privileged.
https://e926.net/wiki/show?title=e621%3Arules

Account elevations are given out on a completely arbitrary basis of "If an admin notices you doing a bunch of helpful things and happens to like you." The secret admin forums probably have a list of potential admin or mod candidates, but "Contributor" is given out to pretty much any artist who asks for it even though it has more account privileges than the "Privileged" account that users are supposed to work hard for.

It is a mystery~

These can be fun to explore
https://e926.net/user
https://e926.net/mod_action?moderator=&body=&type=changed_user_level


Well, if you're a really good user, you get to go up on the model user picture board (Privledged). However, that's nothing compared to actually working on the student council (Artists at contributor). They actually do a lot of work to help keep the school (e6) running, compared to the model students simply being stellar examples others should look up to. Usually. ;P


Sorry to necro this, guys, but I need help installing.

I try and install this thing in Chrome, but I get a small box saying "Apps, extensions and user scripts cannot be installed from this site". Help plz?


Ryuzaki_Izawa said:
Sorry to necro this, guys, but I need help installing.

I try and install this thing in Chrome, but I get a small box saying "Apps, extensions and user scripts cannot be installed from this site". Help plz?

Download the script to your desktop, open you extension manager ('=' button > tools > extensions), tick "Developer mode" checkbox and then drag and drop the script on the crome window and finally click "Add"

Also, no need to worry for necroing this! I think


Xch3l said:
Download the script to your desktop, open you extension manager ('=' button > tools > extensions), tick "Developer mode" checkbox and then drag and drop the script on the crome window and finally click "Add"

Nope, it doesn't work :(


Ryuzaki_Izawa said:
Nope, it doesn't work :(

I tried it again and it still worked

Which version do you have? I have 32.0.1700.102m


Ok, I've just installed this script, and I have to say it looks pretty neat. Though I do have one problem. I'm usig the Chromium-based Comodo Dragon browser and the settings panel for the script was simply unwilling to show itself. I had to use the browser's built-in dev tools to disable its "display: none" property so I could actually take a look. You might want to look into this. I'm using the browser as a portable install (my default is still Chrome, my parents and brother use that).
Edit: I looked at the console to see if anything comes up and I found an error message that appeared whenever I clicked the eSix Extend Settings tab. It says:

Uncaught ReferenceError: $j is not defined (script.js:428)

Hope this can help.


EsalRider said:
Ok, I've just installed this script, and I have to say it looks pretty neat. Though I do have one problem. I'm usig the Chromium-based Comodo Dragon browser and the settings panel for the script was simply unwilling to show itself. I had to use the browser's built-in dev tools to disable its "display: none" property so I could actually take a look. You might want to look into this. I'm using the browser as a portable install (my default is still Chrome, my parents and brother use that).
Edit: I looked at the console to see if anything comes up and I found an error message that appeared whenever I clicked the eSix Extend Settings tab. It says:

Uncaught ReferenceError: $j is not defined (script.js:428)

Hope this can help.

That might be a problem with jQuery, in any case, I was thinking of removing the sliding effect (that should appear when switching tabs).

BTW, when you click "Respond", does the reply box fades in?


Xch3l said:
That might be a problem with jQuery, in any case, I was thinking of removing the sliding effect (that should appear when switching tabs).

BTW, when you click "Respond", does the reply box fades in?

It fades in no problem.


EsalRider said:
It fades in no problem.

Hmm, let me see what I can do... or should I remove the effect?


Xch3l said:
Hmm, let me see what I can do... or should I remove the effect?

Sorry for not replying for so long. You may remove the effect if you want to, but the decision is yours. If the only one having problems is me, then it doesn't matter.
On a possibly related note, are you using jQuery for the pool navigation hotkeys? Because that feature's broken for me as well. I click the Read button, shortly it greys out and says "ready". Nothing after that. Reloading the page (or visiting another post in the pool) results in the navigation guides showing up along with a "stop reading" button. However, the hotkeys are not working. The "stop reading" button also seems to do nothing until the next visit, when the "read" button becomes available again.
Sorry if I'm trouble, just saying that it doesn't work for me. And if it's a jQuery problem, could you assist me in fixing it?


EsalRider said:
Sorry for not replying for so long. You may remove the effect if you want to, but the decision is yours. If the only one having problems is me, then it doesn't matter.

I did it as a general question for everyone, and also asked because e6 barely has some effects (fades)

On a possibly related note, are you using jQuery for the pool navigation hotkeys? Because that feature's broken for me as well. I click the Read button, shortly it greys out and says "ready". Nothing after that. Reloading the page (or visiting another post in the pool) results in the navigation guides showing up along with a "stop reading" button. However, the hotkeys are not working. The "stop reading" button also seems to do nothing until the next visit, when the "read" button becomes available again.

Whoops! I think I overlooked that. I normally click the button inside a pool and click the first post in it. The Stop Reading button doesn't do much, it hides the navigation buttons and "forgets" you were reading that pool. As for the hotkeys not working (probably in Firefox too), is a small wrong case in the event name ("keyDown" instead of "keydown", Opera accepts both while others don't), not in jQ (which I'm not using for this).

Sorry if I'm trouble, just saying that it doesn't work for me. And if it's a jQuery problem, could you assist me in fixing it?

Trouble? Nah! Maybe the problem is because I'm assuming e621's jQuery (the one I'm using by calling to $j) will work inside userscripts (which does in Opera and Firefox, I kinda overlooked Chrome, sorry). I'll try to replicate (and fix) it in Comodo (and Chrome) once the login problem I'm having is fixed.


Okay, so far, the only way to fix this issue with Chrome (and Chromium based browsers) is installing Tampermonkey (Greasemonkey version for these browsers) because Chrome's native userscript manager installs them as extensions and does not allow access to the page's innards (variables, functions, etc.)

But while I was at it, fixed the hotkey issue that wasn't working with Firefox (at least for me) :)

New update coming in a while. Edit: Putting it tomorrow. Having a bit of a problem with remembering what's new on this version :I


Nother update! Please check on page 1 for the whole changelog, sorrz for taking a lot to post this (brother visit)

[02/09/14] Version 2.63 (Code 090214)

  • F: Improved the way settings panes look. No more floating tabs while switching panes
  • C: "Count tags" button now disables itself while still displaying the number of tags
  • A: New "Add tag" button that will add the tag on the "Check Tag" box to the tags list. It checks if the tag exists to avoid adding it again
  • A: "Get Source" now includes derpibooru as a place to find sources when "mlp" is found on the post's tags
  • A: "Common tags" group on posts listing to add to your search. This list includes the 30 most common tags on the current page sorted by how many posts have them
  • A: Included "takedown" as well as "take-down" as stated in point 2.3 in the latest update for the thumbnails in takedown requests (so much as!)
  • F: Clicking "Read pool" will now take you to the first post on that pool or show the navigation controls when in a post
  • F: Hotkeys not responding problem in Chrome/Firefox (forum #103031)
  • F: Hotkeys responding while typing in the reply box

I also updated the original post to include most additions the script makes on the site


And another one! :)

[02/13/14] Version 2.8 (Code 130214)

  • A: TinyAlias. A quick way to add several tags with just one [forum #89046]
  • A: Direct link in the UserBar to the "Upload Post" page
  • A: Option to fix the UserBar in its place
  • A: Line-Ending selector, for those non-windows users. Might save you a character in each new line while blipping
  • F: Some typos and rewording in the settings
  • F: Changed the text size on some places (mainly in the settings page)
  • F: Deleted post's thumbnails in takedown requests don't appear anymore
  • F: Annoying log in the console when adding a link
  • F: Searching for recently PM'd users now looks into hidden PMs

And again, I updated the original post with more recent screenshots and an updated UserBar and the newest feature: TinyAliases. Information on how to use them is located at the settings page, last section. The script will notify you when it's time to update your settings.

Remember to click "Apply" and then "Save" when you finish adding your TinyAliases to store and use them.

Now, if you excuse me, I'm going to sleep, it's 4:20Am and I feel a bit tired z_z


Uhm... Tampermonkey's not willing to update the sctipt automatically. Manual update via userscripts.org makes a warning about a script (or did it say extension?) downgrade. Weird.